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1. Preface 
 
The idea to write this handbook came after the web pages for gOpenMol had been 
updated in the summer 2003 (http://www.csc.fi/gopenmol). The old manual was merely a 
collection of different help texts that were gathered from the program’s Help menus. 
Moreover, the old manual had become out-of-date because in autumn 2003 a new version 
(v. 2.20) of gOpenMol was released. Since I had updated the gOpenMol web pages and 
had probably the best overview of the program at that time, I was given the task to update 
the old manual.  
 
This new handbook is intended to new gOpenMol users and many of the features have 
been given a more thorough description than what was given in the old manual. 
Hopefully experienced gOpenMol users will also find this new handbook useful. The 
program has been available for since the middle of the 1990’s. Thus, there is a large 
gOpenMol community, which shares thoughts and ideas about gOpenMol through their 
mailing list. To join the mailing list go to http://listserv.funet.fi/archives/gopenmol.html.   
 
My thanks go to Leif Laaksonen, who has helped me in defining the purposes of some of 
the options and to Juha Haataja, who has helped in revising the language and guiding the 
process of making a consistent handbook. 
 
 
Helsinki 3.9.2003 
Minna Varis 
 

 3



2. Introduction 
 
This chapter gives a short introduction to gOpenMol, its properties and functions.  
 
The cube file format used by gOpenMol is .plt, if not stated otherwise. All imported 
data must first be converted to .plt format before they can be displayed in gOpenMol. 
The tools for these conversions are available in the menu Run. In almost all windows 
there are present buttons Apply, and Dismiss. Pressing Apply will execute the command, 
and Dismiss closes the window without change. If the operation needs input files, the 
names of the files can be typed into boxes reserved for input file names, but more often it 
is more convenient to click the button Browse and search for the file in that way.  
 
gOpenMol is used through three windows with different properties. In the Graphics 
window (A) the molecules are displayed. The Graphical user interface (GUI) window (B) 
is used to control actions in the Graphics window. In the Text output window (C) the 
output text of executed commands is displayed.  
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The GUI window (B) can be divided into several sections. In the figure above these 
sections are numbered and the explanations to the sections are listed below in numerical 
order. 
 

i. Menu bar 
ii. List of structures loaded into gOpenMol 

iii. Transformation:  Global  applies the transformation to whole 
space. 

  Local    applies the transformation only to the selected 
         atoms or structures. 

iv. Rotate / Translate: when dragging with left mouse button (LMB) and radio 
button for Rotation is selected, the movement rotates the structure to the 
wanted direction. Marking of the radio button for Translation, the molecule is 
translated along Z-plane. 

v. Selection on/off: This is by default off, but if some specific movements or 
commands are applied to just a selected subset of atoms, selected through the 
option select, this must be turned on to be able to do the things a user wants to 
do. 

vi. Instant update on/off: This option is a remainder of “the old times”. 
Previously, computers slowed down remarkably, if several heavy tasks were 
run at the same time, such as rotating a molecule and trying to display the 
molecule at the same time. By turning the “Instant update” off, a user could, 
e.g., rotate the molecule more rapidly, and check every now and then in which 
orientation the molecule was by pressing the gOpenMol logo at the upper 
right corner of the GUI window. With modern computers, though, this usually 
is not necessary, since they are powerful enough to cope with several tasks at 
the same time. 

vii. Pick atoms on/off: Atoms can be picked and the atom info is displayed in the 
text output window (C), when the mouse is run over an atom.  

viii. The command line interpreter, also a remainder of the old times. gOpenMol 
can also be run through command lines but, nowadays, the GUI is used for 
this purpose. 

 
There are also some shortcut buttons included in the mouse and keyboard. Abbreviations 
used here are: LMB = the left mouse button, MMB = the middle mouse button, RMB = 
the right mouse button and Ctrl = the Control key. 
 

• LMB rotates and translates the molecule depending on which radio button is 
selected, the one for rotation or the other for translation. 

• Shift and LMB translates the molecule in the XY plane if the rotation mode is 
selected. If the Shift button is released before LMB, the translation mode will 
remain turned on. To get back to the rotation mode, just hold down Shift and click 
with LMB while holding the Shift-button down and then release the Shift-button.  

• MMB rotates the molecule around the Z-axis. If no three-button-mouse is 
available Alt + LMB does the same job. 
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• RMB is used to zoom in and out of the molecule. To zoom in, hold RMB down 
and drag the mouse up. To zoom out hold RMB down and drag the mouse down.  

• Ctrl pressed down and clicking with LMB is used to pick atoms for importing 
atom(s) into input windows. Press Ctrl down and click an atom you want to select 
with LMB. Keeping Ctrl down press LMB down above the selected atom and 
then drag that atom to a selection box with the mouse pointer To select several 
atoms, pick them one by one and finally take them into a selection box by holding 
the Ctrl key down and pressing LMB down above one of the selected atoms and 
dragging the mouse pointer to an atom selection box.  

• To unpick atoms, hold down Ctrl and click the picked atom with LMB. Again, if 
you release Ctrl button before the mouse, this mode will remain turned on. To get 
back to the unpicking mode, hold down Ctrl and click with LMB and release Ctrl 
after you have clicked with LMB.  

 
Sometimes rotating with the mouse can be rather crude. Molecules, which have to be 
rotated very precisely, can be rotated through the option Rotate/Translate in the menu 
Edit.  
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3 Description of the menus 
 
This chapter reviews all the menus in gOpenMol menu bar and the operative functions 
these menus contain. The menus will be overviewed from left to right and functions 
belonging to a certain menu will be overviewed from top to bottom. 
 
3.1 File 
 
Open 

Read in a previously saved .gom file. The file is an ascii file, which contains 
information about the molecular display at the time when the file was saved. 
Currently it will contain information about the atoms, rotation matrix, and contour 
data. There are still some options which will not be saved but eventually all the 
information will be saved to continue a session.  

 
Save 

Save current display information into the same .gom file.  
 
Save as 

Save the current display information into a new .gom file.  
 
Import 

Cluster… 
Read in a pre-calculated cluster data for display. The cluster data has been 
calculated using the option Cluster in the menu Calculate.  

 
Coords… 
Import molecule coordinates into gOpenMol. The supported coordinate file 
formats are automatically recognized by the file extension. This option can be 
turned off by unpicking the box “Select file format by extension”. In this case the 
supported file formats are listed on the right hand side of the window and the 
proper file format can be selected by picking the radio button next to it. Click 
Browse to search the coordinate files. Use “Append structure” to import several 
structures into the same graphics window. If the box “Calculate connectivity” has 
not been selected, the program will not draw bonds between any atoms. The 
imported coordinate file can be viewed by clicking button Peek file before it is 
processed through the input filter.  
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Figure 1: The window for importing coordinates after “Select file format by extension” has been 
marked off. If the box “Select file format by extension” is marked the coordinate format list on 
the right hand side will not be visible. 
 

The supported file formats are: 
ADF Amsterdam Density Functional program output log files.  
CHARMM CHARMM coordinate (crd) file. For the format please look into 

your QUANTA/CHARMM documentation or the source code.  
CML Chemical Markup Language coordinate file. 
DL_Poly DL_Poly CONFIG coordinate file.  
Frame  The coordinates are taken from a trajectory file.  
GAMESS  The GAMESS PUNCH file (dat) containing the MOLPLT 

information produced with the MOLPLT=TRUE. option.  
GAUSSIAN The coordinates are imported from a GAUSSIANXX formatted 

checkpoint file.  
GROMACS  GROMACS gro coordinate file.  
GROMOS96  GROMOS96 coordinate data file.  
GXYZ Simple xyz coordinate input format specific for gOpenMol.  
HyperChem HyperChem input coordinate (hin) file.  
Insight Insight coordinate (car) file.  
Jaguar Jaguar output log file.  
MOL2 Mol2 coordinate file format.  
MOPAC Coordinates are imported from a MOPAC unformatted graphics 

output file.  
MUMOD Coordinate format used by the MUMOD program.  
OpenMol Formatted coordinate input file to OpenMol.  
PDB The standard Brookhaven Protein Data Bank format.  
Tinker The Tinker coordinate input format 
Turbomole Turbomole coordinate file 
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UHBD University of Houston Brownian Dynamics (UHBD) qcd 
coordinate reader.  

User User defined coordinate input reader. 
Xmol Xmol coordinate file format. The file can contain multiple entries 

but gOpenMol reads only the first entry.  
XYZ Xmol coordinate file format. The file can contain multiple entries 

but gOpenMol reads only the first entry.  
YASP Coordinate input file to the YASP program by Dr. Florian Müller-

Plathe.  
 

In this list Chem3D and Spartan coordinate filters are not displayed. If the user 
has a coordinate file in either of these two coordinate formats, the filters can be 
turned on through Tools > DLL/SO plug-ins > Enable Chem3D/Spartan 
coordinate filter. After turning this filter on, these two coordinate formats will be 
displayed in the coordinate format list of the Import coordinates window. 

 
Dict… 
This facility imports a dictionary file. A dictionary file defines the mapping 
between a residue and atom name into the atom type space (and atom partial 
charge). 
 
The dictionary file can look like the following: 
*Atom dictionary file 
ALA N 32 -0.35 
ALA HN   1  0.25 
ALA CA 10  0.00 
ALA HA   3  0.10 
ALA CB 10 -0.30 

 
The dictionary file contains a residue name, an atom name and maps these into an 
atom type in the used force field (CHARMM in this case) and an atom partial 
charge. This is one of the possibilities to assign an atom type and an atom partial 
charge to the atoms. 

 
GBasis… 
Imports a Gaussian basis set for gOpenMol. There is one sample file named 
gbl_line_input.data in the data directory . This is a feature reserved for future 
purposes. 

 
Vector data… 
Import Atom vector data. gOpenMol can read in two types of vector data: 

• CHARMm data which defines vector properties for atoms in a molecule. 
The file extension is .crd and the file format is the same as in the CRD 
files except that the vector directions are defined x, y and z. 

• Vector file as a flat formatted text file which contains the vector 
information.  
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Tcl script… 
With this function user can import, edit, and execute a Tcl/Tk script. After 
choosing this option, a “Read Tcl file” window opens. Choose the script you want 
to run by clicking Browse and open it. Before the script can be run, it is imported 
to a “Display/Edit Tcl script” window, where some last modifications can be 
done. Click Run Tcl/Tk script to execute. Close window by clicking Dismiss. If 
the script was modified before execution, it can be saved by clicking button Yes 
after Dismiss has been pressed. The program automatically asks if you want to 
save the script of not.  

 

 
 
Figure 2: A screen capture of the Display/Edit Tcl/Tk script window, where a sample script is 
displayed. 
 

Atom charges… 
This function imports charges extracted from output files of programs Gaussian, 
Icon8 and Mopac. It is also possible to import atom charges from output files of a 
user defined program. From the output file of Gaussian Natural population 
analysis, Merz-Kollmann, and Chelpg charges can be extracted.  

 
Export 

Cluster… 
A previously calculated cluster matrix can be exported from gOpenMol to be used 
by other programs, or to be read back to gOpenMol at a later time. The file will be 
saved as a .dat file. 

 
Coords… 
The coordinates of a selected structure can be exported to another file format. 
Only one structure can be converted at a time. Type the file name into the text 
field or select a previous file through Browse. To be sure into which directory the 
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file is saved, click Browse and find the proper directory. The supported file types 
are: CHARMM, CML, OpenMol, PDB, Tinker, UHBD, VRML, and Xmol/XYZ. 
Mark the radio button next to the appropriate file format. The exported file format 
can be automated by marking the box “Select file format by extension” but this 
will export the structure in the same format as it was imported. The VRML file 
export facility is very crude. Currently it only supports line drawing, CPK and the 
licorice display styles.  

 

 
 
Figure 3: A screen capture of the Export coordinates window. 
 

Correlation… 
Writes a correlation data calculated during the time analysis in trajectory analysis 
for molecular dynamics trajectory files.  

 
Input 
Using this widget it is possible to export input files for programs GAMESS, 
ICON8, , MOPAC6, and Probesurf. There is also a possibility for user defined 
output rules through option User. 

• User  
User can make his or her own output rules by modifying the procedure 
lulMakeUSERinput in the gopenmolrc.tcl script in the data directory. 
To use this function, programming skills and knowledge of Tcl/Tk 
scripting language are required and, thus, this function is recommended 
only for experienced gOpenMol users. 

• GAMESS (raw input) 
• ICON8 Extended Huckel program (quite complete) 
• Mopac6 (raw input) 
• Probesurf, a Connolly type of program (complete) 

 

 11



 
 
Figure 4: A screen capture of the Export coordinates window. 
 

RDF 
Export a radial distribution function file calculated with gOpenMol through the 
option Calculate > RDF. The file can be displayed in any of the plot programs 
available, e.g., GNUplot.  
 
Timeseries… 
Export time series data into a separate file. Select the type of time series array and 
the number of the distance, angle or torsion array to be exported to the file. Give 
the file a name directly or choose a name using the file browser by clicking the 
Browse button. By clicking Browse you can check into which directory the time 
series file is being written. To write the information press Apply. 

 
Reset 

Atom colors 
Resets the atom colors to their original ones. 
 
gOpenMol 
Resets gOpenMol and frees all reserved memory as well as destroys all display 
information and up-loaded structures. 
 
View 
Resets the view to the start-up view. 
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Hardcopy  
Creates a picture of the display in the 3D window. The picture can be generated in 
the following formats: Microsoft Windows bitmap (BMP), PostScript (PS), 
Silicon graphics RGB, JPG, Targa (TGA) and X-Windows (XWD). On the top of 
the window there are the radio buttons for the supported formats. Choose the 
appropriate format, type the name of the file in the “File name” box and press 
Apply. Click Browse to go to the proper directory. For PostScript format it is 
possible to choose the orientation of the picture: portrait or landscape.  

 

 
 
Figure 5: A screen capture of the Hardcopy window. The file formats are listed at the top of the 
window, PostScript format being marked here. For other file formats the “Orientation:” section 
of this window will be shaded with grey to indicate that this option is no available. 
 
Exit 

Exit the program and destroy all unsaved data. 
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3.2 Edit 
 
Copy… 

This property works only in Windows. The copied properties can be pasted to 
other documents by pressing Ctrl + V. 
• Bitmap Copy current graphics window into clipboard 
• Correlation Copy correlation data into the clipboard 
• MSD Copy the Mean Square Displacement data into clipboard 
• RDF Copy the radial distribution function into clipboard 
• Timeseries Copy time series into clipboard. 

 
Cell… 

If the user has a molecular dynamics simulation (trajectory), which uses a 
periodic boundary conditions, a cell that has been defined around a certain area 
can be helpful. The cell properties and the cell display properties can be defined 
and edited using this option.  

 
Define the lengths of the edges of the cell, a, b and c (in Ångströms) and angles α, 
β and γ (in degrees). Currently, the angles can only be 90°. The cell is by default 
placed at the center of the screen (or around the 0.0, 0.0, and 0.0). However, the 
cell can be translated by defining the translation distances “X trans”, “Y trans”, or 
“Z trans”. The cell is displayed by changing the ”Display state” to ON. The color 
and the width of the cell edge line (in pixels) can be changed. Click on the button 
Color to change the color of the cell edge (default color is red). To define the 
thickness of the cell edge, type a value in the box next to text “Line width” 
(default: 1). 

 
Center… 

This option defines a new center of rotation for the system. The system can be 
centered on a given atom or atoms. Choose the structure (= segment) and a 
residue or several residues in that structure and a single atom (if only one residue 
is selected) or multiple atoms to which to center the system. If there are several 
structures, the segment must be defined in order the center of the rotation to be 
properly defined. For a single structure, the selected structure is automatically the 
one which is displayed. The system can also be centered according to absolute x, 
y, and z values. In that case segment corresponds to x, residue to y and atom to z. 
Click Apply to center the system.  

 
Identify Atom… 

This widget enables the user to identify full properties for an atom by clicking that 
certain atom. Clicking the ”Identify atom(s)” state ON turns the left mouse button 
to a pointer with which to pick atoms for identification. Move the arrow over an 
atom and the window “Identify atom” will be filled with atom information about 
that particular atom.  
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Figure 6: The Identify atom window. In this case the “Segment” and “Residue” contain the same 
text, because the sample molecule was a chemical compound. In the case of, for example, protein 
structures, the “Segment” would contain the name of the structure and “Residue” the name and 
number of an amino acid residue in that structure. 
 
Light Properties… 

Edit the light properties, i.e., the color components (RGB) and the position of the 
light. The color components of the light are adjusted by changing the red, green 
and blue color intensities using the color sliders. If the atoms are displayed as 
sticks or a structure as trace, this will not have any visible effect on the light 
properties. To see the effects, display atoms, for example, as licorice or a structure 
as any of the other plumbers. The light comes by default along the z-axis (C = 
centered) but it can be changed to come from the north (up), north east (upper-
right corner), east (right), south east (lower-right corner), south (down), south 
west (lower-left corner), west (left) and north west (upper-left corner). Select the 
light position by clicking the appropriate radio button.  

 
Material Properties… 

With this option it is possible to edit/modify surface material properties. It is 
possible to change the material specular red, green and blue colors and material 
shininess. The color components define the color of the reflecting light and the 
material shininess defines the “width” of the reflecting light (0 = wide and 128 = 
very concentrated). The new properties are shown immediately while you change 
the slider values since the radio button “Continuous display” is marked on by 
default. If “Continuous display” is turned off, the effects of this option are 
displayed by clicking the Apply. 

 
Merge Structures… 

Merges all the structures in the 3D window to one the way they are displayed at 
that moment. It is not possible to select only some of the molecules for merging.  
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Molecule… 
With this option the molecular geometry can be edited. Currently one can create 
and break bonds as well as search for disulphide bridges (S-S bonds). Define 
atoms you want to connect or disconnect in Atom #1 and Atom #2 boxes and 
click either the Create bond or Break bond button. S-S bond algorithm searches 
for sulfur atoms inside a radius defined in the “Calculate S-S bonds (Angstroms)” 
box. The atom around which S-atoms are searched for is defined by Atom #1. It is 
also possible to delete or create all bonds from a certain atom or certain atoms by 
defining that atom in Atom #1 and deleting the atom selection input form the 
Atom #2 list. 

 
Rotate/Translate… 

Usually the molecules are rotated and translated with the mouse. If one wants, 
however, to have very precise rotational or translational movements this option 
might prove useful. With this option the user can rotate or translate the 
molecule(s) in the 3D window by single steps defined separately for each axis. 
Rotation steps are defined as angles and translation steps in Ångströms. The 
rotation/translation will be applied on the whole display or just to a selected 
molecule depending on whether the radio buttons of “Apply on” are marked to 
“Display” or “Selection”, respectively. 

 
Select… 

The “Select” command might seem equal to the “Pick” command, but they have 
distinct properties. On selected atoms different operations, which are not possible 
for picked atoms, can be done. To select an atom or several atoms, define the 
atom(s) in the selection boxes; which segment and residue the atoms belong and 
finally the atoms in the “Atom” box. If there are more than one structure 
displayed, the structure, where to select the atoms must be defined by marking the 
appropriate radio button in the structure section of the “Select atoms” window. 
Selected atoms or groups of atoms can be rotated and translated independent of 
the rest of the structure if the radio button “on” in the “Selection” section on the 
right hand side panel of the GUI window is marked.  

 
Stereo… 

Pair 
Displays the 3D window as a pair wise or “crossed-eye” stereo picture. The 
structures are duplicated, separated by a user defined distance, and tilted by a user 
defined angle relative to each other. A positive value for the angle will turn the 
molecule to the right and a negative value to the left around the y axis. This 
property does not work as it should, because the distance varies when the view is 
zoomed in and out. This is the same function as in View > Stereo > Pair. 

 
Display properties… 

Defines the display properties in the 3D window, i.e., the background color, the 
bond display type (Half or Smooth), the color display type (Color or Grayscale), 
the color mapping type (Texture or Rainbow), the drawing buffer (Front or Back), 
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the cutplane distance, the projection (Perspective or Orthographic and the 
Viewing angle in degrees), redisplay and scaling types (Fast or Slow, and Global 
or Local, respectively), the stick display width, the window update (Automatic or 
Manual) and the windowing type (Single or Multi). The different display 
properties can be edited according to the alternatives displayed. For the above 
mentioned options the default display property is marked in italics.  

 
Display list properties… 

Defines whether the “Display list state” for this session, the “Default for new type 
of objects” and the “Use display lists for molecule” are turned on or off. By 
default all these options are turned off. 

 
3D => 2D 

Transforms a 3D structure coordinate file into a 2D coordinate file. This option is 
useful when, for example, making a database of small molecules. A 2D map does 
not require as much disc space as a 3D map. 
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3.3 View 
 
Atom color 

The color of individual atoms or atom groups, such as amino acid residues, can be 
changed with this option. First, the atoms or atom groups are defined, after which 
the color is picked by clicking the button Choose colour…. If the partial charges 
for atoms have been defined, it is also possible to color the atoms according to the 
partial charges. Define the partial atom charge range and press the button Apply. 
The color ranges from blue (lower limit) to red (upper limit) through green. To 
reset all atom colors to their default, leave asterisks in the segment, residue and 
atom boxes and click Reset atom colour. Atom colors can be restored to the 
original ones also through File > Reset > Atom colours. 

 
Atom label(s) 

The selected atoms can be labeled with three types of labels:. Residue displays the 
residue name with three letter code and the amino acid number, Atom displays the 
atom type (e.g., C, CA, N, O) and atom number and Full displays the full atom 
label, which includes the segment number, the residue name and number as well 
as the atom type and number. If you do not want to display, e.g., residue on each 
atom on the labeled residue, define an atom to which attach the label, e.g., CA. 

 
Atom tree 

Lists the atoms of a structure by different structural levels. For example in a 
protein structure the atoms are grouped according to the amino acid they 
compose. The properties of individual atoms can be edited by clicking an atom in 
the list and editing the properties in the window section on the right by clicking 
twice on a property. Do not double click. Instead, click rather slowly. 

 
Atom mask 

Atom mask is used to display or hide a set of atoms in a structure. Define the 
section, residue and atom in the appropriate boxes and define the action “On” or 
“Off” for displaying atoms or hiding atoms, respectively, and press Apply. It is 
also possible to display or hide all atoms of a particular type within a defined 
radius around a defined atom or defined atoms. The color of the atoms within that 
certain radius can be selected through Click to change colour. The atom 
selection can be based on either atoms inside whole residues or just the atoms that 
satisfy the selected radius. 
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Figure 7: The “Atom mask” window. The different sections in this window are described in the 
text for “Atom mask”. 
 
Atom type 

Edit the display type of the atoms. The options are stick, CPK and licorice. Stick 
is the default display type and turning this off will hide all the other display types. 
CPK displays the van der Waals radius of the selected atoms. Licorice displays a 
molecule as a solid stick or by redefining the cylinder and sphere radius, the 
molecule can be displayed as ball-and-stick. 

 
Background color 

Select the background color of the 3D window. 
 
Color 
This option is for Windows. Pick a new color from the basic colors or define a 
color of your own from the color palette. 
 
RGB  
This option, on the other hand, is for other OS versions, because the above 
mentioned does not work for them. Use the sliders to define a new background 
color. 
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Measure 
Measure distance(s), angle(s) and/or torsion angle(s) between selected atoms. To 
define a distance you have to define two atoms, which will only define that 
distance. An angle will be defined with three atoms and a torsion angle four 
atoms. The three atoms used to define an angle will also be used define the 
distances between these atoms. The four atoms used to define the torsion angle 
will likewise define the distances between these atoms, and, in addition, two 
angles between two of these atoms. Click on the button Apply and the values for 
distance, angle, and torsion angle defined by the selected atoms will be shown in 
the appropriate boxes.  

 
Periodic table 

Displays the periodic table of elements. Clicking an element will display a 
window where the symbol, name, atomic number, Gaussian basis set, Covar 
radius and other Gaussian data of that element are listed. The Covar radius of the 
atom can be modified if needed. 

 
Stereo 

Pair  
Displays the 3D window as a pair wise or “crossed-eye” stereo picture. The 
structures are duplicated, separated by a user defined distance, and tilted by a user 
defined angle relative to each other. A positive value for the angle will turn the 
molecule to the right and a negative value to the left around the y axis. This 
property does not work as it should, because the distance varies when the view is 
zoomed in and out. This is the same function as in Edit > Stereo > Pair. 
 

 
Text output 

Displays the output text of gOpenMol. While running the program a great deal of 
message text or result text from various calculation routines are printed to the 
output text window, where the text can be seen running. However, if you are 
running Windows you will not be able to scroll the output text window to the 
beginning after a while. Moreover, at some times some commands may generate a 
considerable amount of output text, which can be easily copied from the Text 
output, and pasted into other applications.  
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3.4 Calculate 
 
Average structure 

Calculates the average structure from a trajectory, which is a molecular dynamics 
simulation. 

 
Cluster 

Calculate and plot cluster matrix from a trajectory file. Calculate a cluster matrix 
displaying the root mean square (RMS) value for display after a superimposition 
of the selected atoms over the frames in a trajectory. Select the segment, residue 
and atoms defining the structure to be superimposed with the equivalent part in 
the other frames. After selecting the atoms press the Apply button to perform the 
calculation over the frames. After the calculation the matrix can be displayed by 
selecting the “Cluster plot on” option. To free the reserved matrix space, press the 
“Delete cluster data” button.  

 
Connectivity 

With this tool user can recalculate atom connections (bonds) if some of the bonds 
have been deleted or not all hydrogen bonds are displayed in the structure. To 
calculate possible bonds a very simple algorithm is being used. The algorithm 
runs over all the atoms in the structure and uses a range (window) of atoms inside 
which it thinks the bonded atoms are located. The range has a default value, 
which can be checked by using line command show atom window. The range is 
defined so that atoms before and after the specified atom in the structure file are 
checked to find atoms bonded to the specified atom. Some programs place added 
hydrogen atoms at the end of the file, which might prevent the algorithm from 
finding the right bonds. To solve this problem redefine the range. Replace the 
value in the “Atom search window” to one which you think covers the whole 
structure. It is also possible to recalculate the connectivity only for a set of atoms.  

 
Hydrogen bonds 

Calculate hydrogen bonds between atoms according to the structure file. If there 
are no hydrogen bonds defined in the structure file, the function Calculate 
hydrogen bonds will not work properly. 

 
Correlation 

This tool calculates correlation and autocorrelation functions from two time 
series. There are three types of time series for which the correlation and 
autocorrelation functions can be calculated: distance, angle and torsion angle. The 
time series for these three possibilities are stored with a running number. Choose 
first the type of time series and then the running number of the time series inside 
this group. If you choose the same time series for #1 and #2 you calculate the 
autocorrelation function.  

 
Geometry 

Calculate molecular geometry. 
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Mean sqr displ 
Calculate mean square displacement values from a trajectory file. 

 
RDF 

Calculate a single or an average radial distribution function (RDF) from a frame 
or a trajectory. It is possible to calculate a distribution function (g(R)) for an atom 
using gOpenMol from one frame or as an average from a sequence of frames like 
a molecular dynamics simulation. It is possible to arbitrarily choose the central 
atom and the atom(s) around that. If you have only one frame available (you have 
not defined a trajectory file) and you select Calculate > RDF, you will get a 
“Select RDF atoms” window. 
 
The different parts of that window stand for: 
• The “From (center) atom(s):” define the central atom(s) around which the 

distribution will be calculated.  
• The “To (orbiting) atom(s):” define the atom(s) with which distribution will 

be calculated.  
• The “Rcut:” value defines the distance to which the distribution will be 

calculated. 
• “Nbins:” define the number of intermediate values (bins) for which the 

distribution will be calculated.  
 

If the periodic cell inside which your atoms and molecules are located (you have 
most likely been using period boundaries), has not been defined before, it has to 
be defined here. Pressing now the button Apply button calculates the RDF of the 
“To (orbiting) atom(s)” around the “From (center) atom(s)” for the structure 
displayed in the graphics window.  

 
There is now one further entry and button displayed. An entry titled “Number of 
sets” defining how many structures the RDF has been calculated and 
accumulated. It is, thus, possible to read by hand more frames into gOpenMol and 
successively calculate the RDF. After the number of RDFs has been calculated 
(accumulated) it is possible to calculate the average for these RDFs by pressing 
the button calc average.  
 
However, if a trajectory file has been defined before the Calculate > RDF has 
been selected, a different kind of window is displayed. In this case the average 
calculated for the entire frame is possible to get automatically by pressing the 
button Calculate average RDF. The program goes through your trajectory file 
frame by frame and calculates and accumulates the RDF. After the last frame has 
been calculated and accumulated to the RDF, an average RDF of all the frames is 
calculated. It is always possible to export the calculated (accumulated) RDF 
through File > Export > RDF. On Windows platform it is also possible to copy 
the RDF to the Paste buffer through Edit > Copy > RDF.  
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Superimpose 
Two structures that resemble one another can be superimposed by defining 
equivalent atoms or residues in the structures. The number of atoms in the two 
sets must be equal but the atoms itself do not have to be identical. Define the 
residues and atoms for a protein structure or only atoms for a smaller compound 
to be superimposed in and press the button Apply. It is possible to display either a 
short or a long display list of the matching structures. Select the one you want.  

 
Surface centroid 

Calculate the centroid for an isosurface. 
 
 
3.5 Plot 
 
Axis 

Using this function it is possible to select atoms and plot the local coordinate 
system on them. It is also possible to give the x, y and z coordinates where the 
local coordinate system is placed. Give the atom(s) and press the button Apply. 
The selection is additive which means that the new set is added to the old set. 
Moreover, each new atom is in the origo of a new axis system. The whole 
selection can be deleted by pressing the button Delete.  

 
Clip plane 

A clip plane cuts a molecular surface so that the charge distribution inside the 
surface can be observed. Mark the box next to the plane along which you want to 
clip the surface. 

 
Colour scale 

It is possible to include a color scale into the molecular surfaces. A color scale is 
used to display a range of values. The color scale has default colors for min. and 
max. values (blue and red, respectively) as well as for the values in between, 
which range through green, yellow and orange. For example, if a molecular 
dynamics trajectory is defined it is possible to plot the Root Mean Square 
Deviation (RMSD) of a selected set of atoms as ellipsoids. The plot is always in 
the global x, y, and z coordinate system. Supply the min and max values and the 
number of steps (bins) by which the color scale is drawn. To display or hide the 
color scale, choose the proper radio button.  

 
Contour 

All contour files must be converted to .plt format using one of the programs in 
the menu Run before they can be drawn. Moreover, the coordinate file for which 
the grid data was calculated for must be read in to the program in order to display 
the isosurface contour. Through window “Contour control” the contour file, 
isosurface values, surface colors, surface smoothing and many more things can be 
controlled.  
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To display a contour surface, do the following steps: 
1. Read in the atom coordinate information for your molecular system through 

File > Import > Coords. 
2. Open the widget “Contour control” from Plot > Contour…  
3. Click on the button Browse to open the file browser, search for the contour 

surface file and select it. 
4. Press the button Import file below the “File name” box to read in the grid data. 
5. Type the max. isocontour value into the first input field. 
6. Click on the button Colour(#) to choose a color for the surface 
7. The contour surface renderer can be used in two different modes:  

a. direct (fast) mode where no contour polygon data information is saved or 
b. save (slow) mode where the last displayed contour polygon data 

information is saved in an array and can be retrieved with the show 
command. 

8. Press the button Apply! 
 

 
 
Figure 8: The Contour control main window. The contour file read in this examples is 
oxaz.plt. The min. and max. isocontour values are 0.0 and 100.0, respectively, of which the 
isocontour surface corresponding to the value 98 has been selected to be drawn in light blue 
color.. 
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Surface details  
Pressing Details button opens a “Contour Details” window where, from left to 
right, the display state of the surface, the surface smoothness, the contour type and 
the cullface state can be detemined. Moreover, the transparency of the surface can 
be determined in the Opacity section. The lower the opacity value, the more 
transparent the surface gets. Pressing Apply will execute the changes.  

 

 
 
Figure 9: The Contour Details window. See the text above for details. 
 

To delete all data click the button Delete all contours. Unfortunately there is no 
function to delete contours one by one. The mesh data can also be manipulated 
with the program “ContMan” in the menu Run > ContMan. 
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Cutplane 
 

 
 
Figure 10: Cutplane main control window. In this example, the yz- and xz-planes are shown, yz-
plane starting from x=1.524e+001 and xz-plane starting from y=-15.24. 

 
Cutplane plots a cutplane through a contour surface. First, a contour surface must 
be read in, but it does not have to be displayed for Cutplane to work. The planes 
are defined as xy-, xz- and yx-planes. Mark the plane to be displayed and press 
Apply. The place, where the plane cuts the molecule can be edited to one, which 
contains most information. Try different coordinates in the box [x/y/z]-coord, 
where the coordinate for the axis perpendicular to the plane is typed. Determine 
min. and max. values of the range. by default the absolute min. and max values 
are given. It is also possible to animate or move the planes “smoothly” using the 
animate facility. Press one of the three Animate buttons to open the animation 
control window.  
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Figure 11: The Cutplane animation control window, named as “Animate contour plane control 
(axis definition: x, y, or z)”. From left to right, the symbols on the buttons stand for the 
following: [|<] = “To the beginning of the animation”, [<] = “Play the animation 
backwards”, [<] = “Play the animation backwards frame by frame”, [ ] = “Stop the 
animation”, [|>] = “Play the animation forward frame by frame” [ >] = “Play the animation 
forward” [ >|] = “To the end of the animation” 

 
To delete all data click the button Delete all contours in the “Cutplane main 
control” window. Pressing the equivalent button in the “Contour control main 
window” does the same thing. Unfortunately there is no function to delete 
contours one by one. 

 
It is not always easy to find the best plane (= plane with most information). To 
make this procedure a bit easier a ”profile graph” can be generated. The graph is 
generated by dividing the range of observations in bins where the grid data is then 
placed. A blue color shows very few observations in that bin, while a read color 
shows a high number of observations in the bin. The current picture applies a bin 
cut value of 1.0, which means that the region shown is the region where there is 1 
or more values in the bin. This bin cut value can be changed by changing the 
default value 1.0 in the input widget to another value. Using the value of 1.0 gives 
already a good insight into the grid space.  

 
LDP 

Plot a linear distance plot for selected atoms. Select the atoms to be include in the 
linear distance plot (LDP), set the LDP plot state to “ON” and press Apply. 

 
Plumber 

With this tool protein secondary structures can be displayed as ribbon (α-helix), 
arrows (β-strands) or tube (both α-helix and β-strands) and also the Cα-trace can 
be displayed as a single line. The Plumber function consists of three separate 
windows, the Plumber (main) window, Secondary Structure window and Plumber 
list.  

 
In the “Plumber” window the user can define which secondary structure is to be 
displayed as ribbon/arrow/tube/Cα-trace and which atoms in the structure are to 
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be displayed. In the Main window, the buttons for displaying “Secondary 
Structure window” and “Plumber list” are the buttons Click for more 
information and List plumber(s), respectively. The color of a particular plumber 
can be selected from Choose colour. The radius of a tube and the groove of helix 
minor and major axis can be edited. “Glue to atoms” glues the plumber to the 
molecule. This is on by default, but if it is not, the plumber and the structure are 
seen as two separate objects, and when rotating the molecule the plumber and the 
molecule might get separated. The box for “Append to stack” has to be marked if 
different kinds of plumbers are drawn for the same molecule, e.g., parts of the 
molecule are drawn as helix and parts as sheet. Moreover, the display state of the 
plumber has to be determined. It is off by default, and if the display state is turned 
on before any plumbers are drawn an error message will be displayed. If this 
happens, ignore the error message, turn the display state “Off” and draw a 
plumber. Then turn the display state on. 

 
Secondary structure window displays the secondary structure regions of the 
structure. The secondary structure information is read directly from the structure 
coordinate file (usually a PDB file). Regions not determined as either α-helices or 
β-strands are considered as loops. The option trace determines automatically the 
Cα-trace of the molecule. To create a single α-helix or β-strand, mark the 
secondary structure to be displayed, press Select and then click Apply in the 
“Plumber” window. Pressing Create all plumbers of this kind will create all 
plumbers of the same sort as the selected one. 

 
Plumber list window: In this window all drawn plumbers are listed. The buttons at 
the bottom of the window stand for following: Select all: Selects all plumbers, 
Select none: Unselects all plumbers; Invert selection: Select the unselected 
plumbers and unselect the selected ones; Select by type: Selects plumbers of the 
same kind as the one already being selected; Change colour: Change the color of 
the plumber; Invert colour: Change the color of the selected plumber(s) to their 
opposite colors; Unglue from atoms: Detaches the plumber from the atoms 
according to which it was drawn; Destroy: Deletes a selected plumber or selected 
plumbers. The Plumber list does is not updated automatically. Pressing Update 
updates the plumber list after actions described above have been executed.  
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Figure 12: The Plumber windows. From top to bottom, Plumber main window, Secondary 
structure window and Plumber list. See text for details. 
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RMSD 
This option plots the root mean square deviation (RMSD) of atom movement in a 
molecular dynamics trajectory. The RMSD is visualized as ellipsoids in the 
selected atoms. The plot is always in the global x, y, and z coordinate system. The 
RMSD can be calculated either by superimposing the individual frames on the 
average structure (= fit) or by not superimposing the individual frames on the 
average structure (= no fit). This is done by marking either of the radio buttons in 
the box “Apply fit”: On (= fit) or Off (= no fit). Press Apply to execute the 
command. The plot can be deleted by pressing Delete. If the fluctuation has small 
amplitude it is possible to increase the amplitude by increasing the value in the 
box “Amplifier factor”.  

 
Vector file 

With Vector file a set of vectors, which are read from a flat text file, can be 
plotted. The calculation can come from GaussianXX, Turbomole, or from another 
program. Enter the name of the file in the box “Vector input text file name” or use 
Browse to search for the vector file. The vectors can be displayed either as lines 
or solid tubes. The line drawing is the fastest display mode and it is recommended 
to use if several vectors are displayed simultaneously. The radius of the solid 
tubes can be edited in the box “Radius” next to “Line” and “Solid” radio buttons. 
It is also possible to define the range of the vector length, which determines which 
vectors are being displayed. Those vectors, which lay within the defined range are 
displayed. The vector display state can be turned “On” or “Off” by marking the 
appropriate radio button. If the vector display is not needed, free all the reserved 
vector space by clicking Click here  in the box “Delete all vectors and space” to 
delete all vectors and space. 

 30



3.6 Trajectory 
 
The functions in this menu are used to control and manipulate trajectories. First a 
trajectory has to be read in through the Main window. Then, before Timeseries option can 
be used, the distance, angle or torsion arrays must be defined through Monitor > 
Distance/Angle/Torsion and the time series vector must be filled through Fill > 
Distance/Angle/Torsion. Only after these steps the time series can be manipulated. A time 
series vector for distance, angle, or torsion can be deleted through Delete > 
Distance/Angle/Torsion.  
 
Fill 

Distance array  
This command fills the time series array for a distance as defined in Monitor > 
Distance. 

 
Angle array 
Fills the time series array for an angle as defined in Monitor > Angle. 

 
Torsion array 
Fills the time series array for a torsion angle as defined in Monitor > torsion. 

 
Delete 

Distance array  
Deletes the distance array information, which has been created through Fill. A 
distance (or distances) defined in Monitor > Distance will still be visible in the 
graphics window and it (or they) will change upon playing the trajectory. 

 
Angle array  
Deletes the angle array information, which has been created through Fill > Angle. 
An angle (or angles) defined in Monitor > Angle will still be visible in the 
graphics window and it (or they) will change upon playing the trajectory.  

 
Torsion array  
Deletes the distance array information, which has been created through Fill > 
Torsion. A torsion angle (or torsion angles) created through Monitor > Torsion 
will still be visible in the graphics window and it (or they) will change upon 
playing the trajectory. 

 
Main 

This opens the “Trajectory control” window through which the trajectories can be 
read in to gOpenMol. Moreover, the displaying of the trajectories can be 
controlled through this window. But before any trajectories can be processed, a 
structure coordinate file must be read in through File > Import > Coords to define 
the molecular topology and the atom labels because some trajectory files contain 
only atom coordinate information.  
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To read in a trajectory, first select the trajectory file type you want to analyze and 
visualize from the list on the right in the “Trajectory control” window. Then click 
Browse and search your trajectory file from your file system. To import the 
trajectory, press Import. After the trajectory has been completely read in the 
number of frames will appear to the “Num of Frames” box, which is shaded grey, 
in the “Trajectory info” section. In that same section also the number of the first 
frame and the last frame are displayed as well as the number of steps (=frames) by 
which the trajectory will be displayed. Usually the trajectories are displayed by 
steps of one frame but the number of steps can be modified to a more suitable 
value. To execute modifications in the number of first frame and the number of 
the last frame as well as in the number of steps by which the trajectory is 
displayed, press Apply at the bottom of the “Trajectory control” window. The 
time frame at which a certain trajectory is displayed can also be slowed down by a 
user defined value. To execute this command, press Apply next to the box where 
the new value was typed. 

 
The supported trajectory formats, which are listed the right on the “Trajectory 
control” window, are:  

 
AMBER  An unformatted binary Amber trajectory file.  
AMBER (F)  A formatted Amber trajectory file. In the bin directory of 

gOpenMol for Windows is the program for making the conversion 
of a formatted ABMER trajectory file into an unformatted one. The 
name of the program file in the Windows distribution is 
ambera2b.exe. The program does not work through the GUI, 
though. It has to be started from the bin directory directly. Then 
the name of the file to be converted is typed on the screen which 
pops up and the conversion is executed by pressing enter.  

 More information about AMBER can be found at the AMBER 
Web pages at http://www.amber.ucsf.edu/amber/formats.html  

Cerius2  An unformatted binary CERIUS2 trajectory file.  
CHARMM An unformatted binary CHARMM trajectory file.  
Discover An unformatted binary DISCOVER trajectory file.  
UDL_Poly  
FDL_Poly  
Gromacs An unformatted GROMACS trajectory files (trn, trr and xtc).  
Gromos  An unformatted GROMOS trajectory file.  
Gromos96A A formatted ASCII GROMOS96 trajectory file.  
HyperChem An unformatted binary HyperChem trajectory file.  
MUMOD An unformatted binary MUMOD trajectory file. The MUMOD 

program is developed by Dr. Olle Teleman.  
TINKER A formatted TINKER trajectory file.  
XMOL  A formatted ASCII XMOL (multi set) trajectory file.  
XPLOR An unformatted binary XPLOR trajectory file.  
YASP  An unformatted binary YASP trajectory file. The YASP program is 

developed by Dr. Florian Muller-Plathe. 
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In the “Trajectory control” window, there are also buttons for displaying the 
trajectory file. These buttons are equivalent to those in “Animate contour plane 
control (axis definition: x, y, or z)” window on p. 20. They stand for [|<] = go to 
the first frame; [<] = go backwards one frame; [ ] = stop the display loop; [|>] = 
display the frames in a loop by steps defined in the “Step frame(s)” box in the 
“Trajectory info” section.; [>] = go forward one frame; [>|] = go to the last frame. 

 
Atom connections and hydrogen bonds are not recalculated by default. In the 
sections to recalculate these connection the radio buttons “Off” are marked. To 
turn on the recalculation option, mark the radio button “On”.  

 
The formatted trajectory files can be retrieved by two ways, the “Fast” way and 
the “Slow” way. The “Fast” method uses a pre-calculated index (jump) vector into 
the trajectory file for the various frames. This method is capable of retrieving a 
frame at a speed independent of the frame position in the file. However, be careful 
with this if you move files between Unix and Windows systems! The “slow” 
method reads all the frames up to the needed frame. This process is very slow for 
big files but it is not sensitive to the characters at the end of the line. 

 
The number of the frame can be displayed in the upper right corner of the 
graphics window if the radio button “On” is marked in the “Display frame nr” 
section at the bottom of the “Trajectory control” window. 

 
Monitor 

Monitor the changes in the molecular geometry of a trajectory. Distances between 
individual atoms in a molecule can also be measured through this function, even if 
no trajectory is defined. 

 
Distance 
Define the atoms for which you want to measure the distance or monitor changes 
in the distance in the sections “Atom(s) #1” and “Atom(s) #2”. If you want to 
change the line color, click Line colour, pick a new color and click Ok. Line type 
can be selected from four alternatives by pressing the button Line type. For 
displaying the distance vectors in the graphics window, mark the Display state 
“On” at the first time, the following distance lines are dawn even if the Display 
state is marked “Off”. When the atoms are defined, press Apply. Each distance 
line will take its own row in the “Monitor distance” window. On that row, the 
atoms, which are used to draw that line are given. The line type and color can be 
changed here, as well. Clicking the Edit button will display “Monitor edit 
distance” window. Here, the atoms used to draw that line, can be changed. 
Pressing Delete in this window does no delete the line for which this Edit window 
was taken for. Instead the lines are deleted one by one in the order they were 
drawn. Delete all in the “Monitor distance” window will delete all drawn lines. 
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Angle  
Like in the “Distance” window, here the atoms to define an angle (three atoms) 
must be given in the “Atom(s) #(number)” sections. Likewise, the line color and 
the line type can be selected before the angle is drawn or they can be edited after 
the line is drawn. The Display state must be marked “On” for the first angle, but 
all the subsequent angles are drawn even if the Display state is “Off”. The Delete 
button in the “Monitor edit angle” window deletes the angles in the order they 
were drawn, one by one. 

 
Torsion 
As for “Distance” and “Angle”, the atoms for a torsion angle have to be defined in 
the “Atom(s) #(number)” sections, four atoms at this time. The rest of the options 
equal to those for “Distance” and “Angle”. 

 
Time series 

Manipulate the distance, angle and torsion time series through the following 
operations:  

 
The types of operations (manipulations) available are: 
DAVERAGE Q(t) = Q(t) -  
SQUARE Q(t) = Q(t) ** 2 
COS Q(t) = cos(Q(t))   
COS2 Q(t) = 3*cos(Q(t))**2 - 1   
SQRT; Q(t) = sqrt(Q(t))  
DINITIAL Q(t) = Q(t) - Q(0)  
COPY nr; Q(t) = Q2(t)   
ADD nr; Q(t) = Q(t) + Q2(t)    
LOG ; Q(t) = log(Q(t))  
EXP ; Q(t) = exp(Q(t))  
POWER REAL Q(t) = Q(t) ** real  
MULTREAL Q(t) = real * Q(t)  
DIVIDEREAL Q(t) = Q(t) / real  
SHIFTREAL Q(t) = Q(t) + real   
DMIN Q(t) = Q(t) - Q(min) 
ABS Q(t) = abs(Q(t)) 
DIVFIRST Q(t) = Q(t) / Q(0)  
DIVMAXIMUM Q(t) = Q(t) /max(Q(t)) (There is a typo in the “Manipulate 

timeseries” window, where is says DAVERAGE) 
PSPECTRUM Power spectrum 
ZERO; Q(t) = 0.0 

 
Mark the radio button next to the desired operation to activate it. If the operation 
requires further a value or an index, fill the value into the input box. Choose the 
distance, angle or torsion option from the “Type of time series” section. Those 
options that have been “filled” through Trajectory > Fill > 
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Distance/Angle/Torsion are visible here. Fill in the number index for the desired 
time series in the “Destination time series nr:” box.  

 
Trace 

With this function the movement of selected atoms in a trajectory file can be 
traced. Define first the atom(s) to be traced (CA, C, N, O, etc.) and press the 
button Apply. Put the display state to “On” by clicking the “On” radio button. 
This has to be done only when the first trace is drawn. The following “traces” are 
displayed even if the display state is “Off”. By marking the box next to “Append” 
traces of several atoms can be displayed simultaneously. Pressing Delete will 
remove all traces. 

 
Make movie 

With Make movie .mpeg animations of trajectories can be made. Unfortunately, 
this will only work on Windows platforms. In other operating systems the single 
files for an animation can be written, but for making an animation a separate 
program must be taken into use.  

 
Make an animation by first creating discrete files of each trajectory frame and 
then by combining these files into a single .mpg file. Currently only files in Targa 
(.tga) format can be used for the making of .mpeg animations but it is possible to 
make the screen dumps of the individual trajectory frames also in Bitmap, RGB, 
and XWD formats. Only small picture sizes can be used so reduce the size of the 
graphics window to gain a 400 * 400 pixel square before the making the 
animation. Enter a root file name in the box below the file formats. This root file 
name will be extended with a serial number of a frame and the file extension. 
These files will be automatically placed in the temp/ directory. Press Apply and a 
screen dump of every frame in your trajectory will be made. After all discrete 
screen dumps have been created, the .mpeg file is generated automatically. 
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3.7 Run 
 
In this menu, the tools for converting output files from a variety of chemical and 
physicochemical analysis programs to the gOpenMol cube files (.plt) are listed.  
 

 
 
Figure 13: A representative window from one of the conversion tools  in the menu Run. 
This same scheme can be applied to all the other conversion tools in this menu. The 
number of input files and some options might differ in the other windows.  
 
AutoDock2plt (map)… 

Run the AutoDock2plt program to convert an AutoDock map file into the .plt 
file format (formatted and unformatted). Type the input and output file names or 
click Browse to find the files and press Apply to convert. 

 
ContMan (plt)… 

Runs the contour management program with which two contour files or two .plt 
grid mesh files can be added or subtracted (A = B + C). Search the input files by 
clicking Browse and give a name to the output file. Search an appropriate 
directory though Browse. Otherwise the output file will be written to the same 
directory from which the second input file was read in. Select from the two radio 
buttons in the section “Action type (-/+)” if you want to subtract the “Input #2” 
from “Input#1” or to add the “Input #2” to “Input #1”. The corresponding radio 
buttons are “Minus (-)” and “Plus (+)”, respectively. The results will be written 
into a .plt file.  

 
Gamess2plt (cube)… 

Gamess2plt converts the “cube” information in a PUNCH file to the .plt format. 
 
gCube2plt/g94cub2p (cube)…l 

Run the program gCube2plt/g94Cub2pl to convert a Gaussian cube file into the 
.plt format. gCube2plt is an old version of the program that converts only one 
orbital or density at a time. The total number of files to be converted has to be 
given in the input field. g94Cub2pl is a modified version of the ole program, 
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made by Doug Moffatt, which converts all the information in a Gaussian cube file 
into separate files in one batch. 

 
Jaguar2plt (cube)… 

Run the program Jaguar2plt to convert Jaguar orbital data to the .plt format. 
 
Join Gamess IRC files 

Join Gamess IRC files into one. 
 
Kont2plt (grid)… 

Run Kont2Plt to convert a grid mesh file from the program Grid into a formatted 
or unformatted .plt format. Choose the appropriate radio button and execute the 
conversion.  

 
Pltfile (conversion)… 

Pltfile converts a gOpenMol .plt file from binary to ASCII or an ASCII file to 
.plt binary. The operation is mostly used to move a .plt file between different 
hardware platforms.  

 
Probesurf (Connolly)… 

Run the ProbSurface program to generate a Connolly surface around a molecule. 
Define the input file in the box for “Input file name” and the output file name in 
the box for “Output file name”. The ProbeSurf calculation can be done either in 
foreground or background. The foreground calculation locks gOpenMol until 
the calculation has been finished. The background mode enables the further usage 
of gOpenMol while the calculation continues. ProbSurf uses a direct (r) and 
squared (r**2) distance method for the calculation of the surfaces. Choose the 
appropriate method and press Apply. After the calculation has been finished it is 
possible to read in the contour file and display the surface. By answering yes to 
the question: “Do you want to read in a Connolly surface?” the new surface will 
be displayed automatically. If you answered no to the question the surface will no 
be displayed.  

 
Socket server client 

Neither Server control nor Client control in this menu work. Socket server 
client has been added to the Run menu for future purposes 

 
TMole2plt (grid)… 

TurboMole2plt converts a TurboMole grid file to the .plt format. The 
TurboMole grid file can then be displayed using Plot > Contour. Type the input 
file name in the appropriate box or click Browse to find the file. Enter the output 
file name in its text filed and press Apply to convert.  

 
UHBD2plt (grid)… 

Run the UHBD2plt program to convert a formatted or unformatted UHBD phi 
grid file to a .plt file. Enter the name of the input file and give the output file a 

 37



name. Select if the input file is a formatted or an unformatted UHBD file and 
make the conversion by pressing Apply. 

 
Xvibs (conversion)… 

Xvibs, which is created by Bradley A. Smith, can be used to make animations of 
molecular vibrations in XMOL format using output files from Aces2, Gamess, PC 
Gamess, Gaussian, and ADF. For each vibration a separate animation can be 
written. Search the input file through Browse and type the number of the 
vibration an animation is created for in the text field for “Vibration(s)”. If you 
want an animation of all the vibrations in the output file, type “all” into the 
“Vibration(s)” text field. Press Apply to convert. The version of Xvibs distributed 
together with gOpenMol is not the lastest one. More information about Xvibs can 
be found at http://xvibs.sourceforge.net. 

 
 
3.8 Tools 
 
DLL/SO plug-ins 

Under this submenu are the extensions that can be implemented as plug-ins to 
gOpenMol. 

 
Enable ball plug-in 
There is no operating function behind this option. For experienced users this 
option shows how to create their own plug-ins. 

 
Enable Chem3D / Spartan coordinate filter 
Selecting this function enables the Chem3D / Spartan coordinate filter, which is 
not on by default. If you have files in either of these two formats, this plug-in 
must be first turned on before the files can be read into gOpenMol. After turning 
on the filter, Chem3D and Spartan appear in the list of coordinate file types that 
can be imported to gOpenMol. Go to File > Import > Coords and mark off 
“Select file format by extension” to see the effect. 

 
VRML 
VRML plug-in is written by Kevin Boyd for gOpenMol version 2.2. This option 
can be used to create VRML (virtual reality markup language) files of trajectories 
displayed in gOpenMol. These VRML files can also be viewed by others through 
the WWW. To view the VRML animations a VRML plug-in has to be installed. 
(For more information, visit 
http://www.chem.utah.edu/chemistry/faculty/anderson/gopen/ 
tutorial.html#vrml) 

 
AutoDock 

This option is used to analyze and to display AutoDock trajectories. At first the 
ligand structure file, the structure file of the molecule the ligand was docked into, 
the trajectory file, and the AutoDock log file have to be read in. Press Import 
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buttons after the text fields for each of file names to import the given file. To add 
ligand structures on top of the first loaded structure, mark the box “Append to 
structure”. Cruncher option creates files where the original and docked 
coordinates are separated into different files.  

 
The AutoDock trajectory file is the ligand.tout file, which is the output of an 
AutoDock run in ASCII format. It is defined in the help pages for AutoDock 
trajectories (http://www.scripps.edu/pub/olson-
web/doc/autodock/trajectories.html) in the following way: “The traj command 
which is used in the trajectory output, creates trajectories in two formats, one in 
PDB format which is written to the log file specified by the -l flag, and one in a 
raw ASCII format which is written to the standard output (ligand.tout). For 
example, if the command issued was: autodock -p ligand.dpf -l 

ligand.trj.conv.log -c < trj.conv.com > ligand.tout, the file 
ligand.trj.conv.log will contain a PDB formatted list of all the trajectory 
steps, while the ligand.tout file will contain raw ASCII data, with one row for 
each atom in the ligand, and each column containing data concerning the ligands 
coordinates, energy states annealing temperature, etc.”  

 
After the structure and trajectory files have been loaded, the number of frames 
should have appeared in the text field next to the text “Num. of Frames” By 
default the display goes from the first frame to the last in steps of one frame. This 
default behavior can be changed by supplying a desired value in a corresponding 
field (“First frame”, “Last frame”, “Step frame(s)”, or “Current frame”). The 
trajectory frames are controlled by using the buttons below the section where the 
frame options were defined. These buttons, [|<], [<], [ ], [|>], [>], and [>|], stand 
for: “go to the first frame”, “go back one frame”, “stop the display loop”, “display 
the frames forward in a loop”, “go forward one frame”, and “go to the last frame”, 
respectively. 

 
The trajectories can be retrieved with either the two methods, which are defined in 
the box “Trajectory retrieval”. The “fast” method uses a pre-calculated index 
(jump) vector into the trajectory file for the various frames. This method is 
capable of retrieving a frame at a speed independent of the frame position in the 
file. However, be careful with this if you move files between Unix and Windows 
systems! The “slow” method reads all the frames up to the needed frame. This 
process is very slow for big files but it is not sensitive to the characters at the end 
of the line. 

 
The ligand and system coordinates can be written as *.pdbq files with the options 
at the bottom of the “Autodock main control” window. This is very handy in case 
you have imported the atom partial charges and want to write a *.pdbq file with 
new charge values.  
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3.9 Help 
 
The help system is built upon a Tcl/Tk based Web browser that has very few features 
compared to the modern Netscape or Microsoft Internet Explorer Web browsers.  
 
About 

Shows the gOpenMol info about the current version, its release date and the 
programmers as well as the copyright information.. 

 
Demo 

Gives a list of available demos. There are short demos for Simple molecule 
display, Molecular dynamics, Orbital and density, Object display, Manipulations 
and Clip plane. Click on an appropriate button to run a demo. 

 
Help 

Shows the help pages for gOpenMol. 
 
Menu help 

Shows the information about the pull-down menu system. It is the same page as 
the “How to begin your gOpenMol session” in the Help pages. 

 
Peek version 

This function tells you if the version you are using is the latest release or an older 
one. Peek version takes an http connection to the gOpenMol distribution site and 
checks for the latest version available. In the pop-up message the version of the 
program which you are using at the moment and the latest version as well as to 
which platforms the latest version is available, are indicated. This feature will help 
you to upgrade and maintain gOpenMol in the future. 

 
Tutorials 

This option gives the list of tutorials for gOpenMol. If you have prepared a good 
tutorial please let us know and it will be included here. To send it, contact Leif 
Laaksonen (Leif.Laaksonen@csc.fi) 

 
Scott’s intro 

This is a link to Scott Anderson’s tutorials in the gOpenMol web. The same 
tutorials can be found in the WWW at  
http://www.csc.fi/gopenmol/tutorials/scott/ or  
http://www.chem.utah.edu/chemistry/faculty/anderson/gopen.html 
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4. Advanced examples for how to use gOpenMol 
 
For some operations it was appropriate to write more thorough descriptions. Because the 
use of these operations requires the knowledge of several features in different menus a 
separate section was made for these functions. For some of the examples, 
demonstrational files can be found in the gOpenMol demo directory. 
 
4.1 Mapping of a contour on a surface 
 

This can be used if information from a contour or surface file is mapped on 
another surface or contour file. There are example files in the gOpenMol demo 
directory. Use density.crd as the coordinate file and density.plt and 
orbital.plt as the grid files. The idea of this example is to plot the electron 
density at an isocontour value (0.1) and map the orbital grid values upon this 
surface. 
 
1. Read in the density.plt coordinate file through File > Import > Coords and 

then two grid files density.plt and orbital.plt through Plot > Contour 
in this order.  

2. Mark the radio button next to “(1) density.plt” to select the file. 
3. Press the button Mapping next to the radio button that was just marked. This 

will open a “Contour mapping control” window, where the grid data to be 
mapped on density.plt can be defined. Press the button which says: “1: No 
mapping” and select from the list “2: orbital.plt”. Press Accept to map 
orbital.plt to density.plt. 

4. With the radio button for density.plt marked, type on the first text field in 
the “Define contour levels:” section “0.1 -0.15 0.15”. The value 0.1 defines 
the surface for density.plt and the values -0.15 and 0.15 define the 
minimum and maximum values for orbital.plt. 

5. Press Apply to see the result in the graphics window. 
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Figure 14: This is an example of what the display in the graphics window should look 
alike if the example files in the demo directory were used. 

 
The Surface details can be edited the same way as described above in Chapter 3, 
section 3.5 Plot > Contour > Surface details.  

 
NB: 
The two grid files have to have the same number of grid points in the x, y and z 
directions and the grid data has to be defined in the same x, y and z space for the 
both grid files. If the grid space of the files is not known, formatted to 
unformatted *.plt file converter can be run through menu Run > Plt file 
(conversion) to check the x, y, and z space for the grid files..  

 
 
4.2 How to glue a surface to certain coordinates. 
 

In the “Contour control” main window there is a button with the text “Glue ==> 
‘name of a coordinate file’”. This defines the structure to which the contour file is 
glued (attached). By default any contour file that is read into gOpenMol is always 
glued (attached) to the structure that was loaded first. There is no meaning for this 
function if only one structure is read in or if the transformation is in the “Global” 
mode (see GUI, section iii) in Chapter 2). This example demonstrates how to glue a 
contour to the structure where it belongs to. There are model files available in the 
gOpenMol demo directory.  

 
1. Import the coordinate files oxaz.crd and orbital.crd from the demo directory 

through File > Import > Coords. Remember to mark “Append to structure” so 
that the previously read structure will stay in the graphics window. 

2. Mark the radio button for local transformations in the section “Transformation” in 
the GUI. The two structures have now their own local centers around which to 
rotate. 
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3. Try rotating and translating both structures individually by emptying the check 
box next to the structure, which should remain unmoved. Remember, that 
pressing Shift and LMB simultaneously translates the molecule? Release the 
LMB before Shift to go back to the “Translation” mode.  

4. Open the “Contour control” window through Plot > Contour. Import the 
oxaz.plt (Connolly type of surface) and orbital.plt (molecular orbital) files 
from the demo directory. 

5. Now, oxaz.plt should be glued on oxaz.crd (or orbital.plt to density.crd 
depending on in which order the files were read in). Press the button Glue ==> 
density.crd on the same line as oxaz.plt to get the “Contour structure combine” 
window. Press the button with number 1 on it and select from the list oxaz.crd. 
Press Apply to change the structure where oxaz.plt is glued upon.  

6. Mark the radio button for oxaz.plt and type the value 40 on the first text field in 
the section for “Contour levels:”, select a color and press Apply. 

7. Mark then the radio button for orbital.plt and type on the first text field in the 
“Contour levels:” section the value 0.1 and on the second text field –0.1, select a 
color for both values and press Apply. 

 

 
 

Figure 15: The result of this example should look something like this. The colors may vary 
depending on which colors you chose for the different surfaces. 
 
 
4.3 How to create Connolly type surfaces with the program ProbeSurf  

 
The program ProbeSurf in the menu Run can be used to generate a surface of the 
Connolly type, which is a mesh with grid values from 0 to 100. The value 100 is 
at the van der Waals value and value 0 is at the van der Waals + max. probe 
diameter value. The values between 0.0 and 100.0 can be calculated using two 
methods. The original article describes a method based on the square distance (r2) 
but the value can now be calculated based on the distance (r) as well. It is possible 
to generate the surface for different probe values.  
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The method is based on the article by R. Voorintholt et al. (Voorintholt, R., 
Koster, M.T., Vegter, G., Vriend, G. and Hol, W.G.J. (1989) A very fast program 
for visualizing protein surfaces, channels and cavities”, J. Mol. Graphics 7: 243-
245.)  

 
1. Import a molecule coordinate file through File > Import > Coords. 
2. Go to File > Export > Input > ProbeSurf where you can write an input file for 

the ProbeSurf program based on your coordinate file.  
3. In the “Export input” window which pops up the radio button for “ProbeSurf” 

is marked on by default. Then type the name of the input file 
input_file.inp in the text field. To find out to which directory the file 
input_file.inp is saved, press Browse. In the section “Choose structure #” 
select the structure for which you want to write the input_file.inp for by 
pressing the button with number 1 on it and selecting the structure from the 
list.  

4. The definitions for the surface can be edited in the text fields for max. and 
min. values for x, y, and z as well as in the text fields for “Points x/y/z 
direction”. The probe radius can also be defined, though, usually the default 
values are ok. 

5. After all above mentioned has been done, press Apply. Make notice of that in 
Windows, the input_file.inp must be written into a directory, which name 
does not contain spaces, because ProbeSurf run through the menu Run will not 
find the input file if the name of the directory contains spaces, such as 
C:/Documents and Settings/User/My 
Documents/gOpenMol/input_file.inp.  

6. In the following “Display/Edit text” window, where the results of the 
“Export” command are shown, press Dismiss instead of pressing Save. 
Pressing Save will give an error message, which can be ignored by pressing 
Ok, though. Now you should have an input file ready for ProbeSurf and you 
can close the windows “Export input” and “Display/Edit text”. 

7. Now go to Run > ProbeSurf and search the input file you just generated 
through Browse on the line “Input file name”. Then type the name of the 
output.file in the text field below the input file name and press Apply to 
run the program. 

8. To the question “Do you want to read in the contour file?” answer “Yes” if 
you want to display the contour file and “No” if you want to do it later. If you 
answered “No”, the surface file can be imported through Plot > Contour. 
Answering “Yes” will automatically import the surface file and open the 
“Contour control” window. 

9. In the “Contour control” window type in the first text field the contour value, 
e.g., 40 choose a nice color and press Apply to see the newly generated 
surface in the graphics window. 
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4.4 How to trace atoms using Trajectory > Trace. 
 
Again, there are model files available in the demo directory.  
 

1. Import the opt4pti.crd file through File > Import > Coords and the 
dyn4pti.dcd trajectory file through Trajectory > Main. 

2. Display only the backbone atoms of the molecule through View > Atom type  
a. Display off all atoms by marking “Display state” “Off” and press 

Apply. 
b. Display only backbone atoms by typing CA,C,N,O to the Atoms-field 

and marking “Display state” “On”. Press Apply to see the atoms. 
c. If extra water molecules are displayed, type HOH into the Residue-

field and mark “Display state” to “Off”. 
3. Open Trajectory > Trace and type into the “Atom” text field CA and press 

Apply. To display the trace for all CA atoms click the Display state to “On”.  
 

If several traces are to be displayed, mark the box “Append” and do as above in 3) 
for another atom type. This time the display state can be left “Off” since the 
second trace will be displayed anyway.  

 
 

 45


